linux install gnome-dekstop error keyword “msgctxt”

I use Linux Centos 5.3 at my computer. I try to install gnome-dekstop-2.30.0.tar.bz2 at my system. To install this source, I use steps:

  1. Ekstract source, I use command:  tar jxvf gnome-desktop-2.30.0.tar.bz2
  2. cd  gnome-desktop-2.30.0
  3. configure source, I use command : ./configure –prefix=/opt/gnome/
  4. make

I get error message when executed make command.


This error happen because Centos 5.3 have gettext version is too old. If we want  check gettext version in linux, we can use command :

msgfmt –version

and we get output from this command :

msgfmt (GNU gettext-tools) 0.14.6

To solve this problem, I will install gettext-0.17.0. To install this source, I use steps:

  1. Download  gettext-0.17.0.tar.gz
  2. Ekstract source, tar zxvf gettext-0.17.0.tar.gz
  3. cd gettext-0.17.0
  4. ./configure –prefix=/opt/gnome/
  5. make
  6. make install
  7. copy gettext original (as backup). I use command : mv /usr/bin/msgfmt /usr/bin/msgfmtold
  8. copy gettext new compiled. I use command : cp /opt/gnome/bin/msgfmt /usr/bin/
  9. check new version of gettext. Use command : msgfmt –version

We must add library path from gettext to my system, so linux can detect new library from source compiled. Edit your ~/.bashrc and add following text  at bottom from this file:

After this step, you must restart or logoff your system and repeat to install gnome-desktop.

One thought on “linux install gnome-dekstop error keyword “msgctxt”

Leave a Reply

Your email address will not be published. Required fields are marked *

 

This site uses Akismet to reduce spam. Learn how your comment data is processed.